FIX PROBLEMA: Il server è in esecuzione la versione di PHP ma WordPress 5.1.6 3.2.1 5.2.4 richiede almeno.

Avviso per tutti non è ben noto che per installare o fare aggiornamentoCPC ad una nuova versione di 3.2È necessario che essere installata una versione più recente di 5.2.4.

Se il server è installare una versione di PHP più vecchio di 5.2.4 per installare la versione WordPress 3.2.1apparirà errore / Message "Il server è in esecuzione PHP versione 5.1.6 Richiede WordPress 3.2.1 ma almeno 5.2.4".
Il problema può essere risolto molto semplicemente con l'aggiornamento di PHP, ma prima di farlo un paio di cose dovrebbe essere considerato. In primo luogo, l'aggiornamento PHP hosting è escluso da una condivisione. Così si può fare l'aggiornamento deve avere accesso come amministratore al server (server dedicato o VPS). Nel secondo, prima che l'aggiornamento deve stare attento a documentare e che nuova versione di PHP non dare Errori altri siti ospitati sul server.

Per OS è il più utilizzato server web (Agreart e / WHM) Vi mostrerà come fare aggiornamento di PHP su CentOS 5.2.10.x 5 32 bit.

L'aggiornamento a PHP 5.1.x 5.2.x su 5 bit CentOS 32.x

1. Controllare quali pacchetti / moduli sono installati PHP (es. PHP-mcrypt) in aggiunta al pacchetto standard. Se del caso, verranno eliminati o actuzlizate.

Controllare i pacchetti installati:

rpm-qa | grep php

old_php_version

2. Aggiungere nuovi archivi richiesto aggiornamentoversione di PHP acquis.

nano / etc / yum.repos.d / CentOS-Testing.repo

Nel file appena creato (CentOS-Testing.repo) Will aggiungere le righe al di sotto (copia / incolla):

[C5-testing]
name = 5 CentOS-Testing
baseurl = http: //dev.centos.org/centos/$releasever/testing/$basearch/
enabled = 1
gpgcheck = 1
gpgkey = http: //dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X per salvare il file CentOS-Testing.repo.

3. aggiornamento PHP tramite yum:

yum update

4. nuovo inizio / httpd :

service httpd restart

Dopo la versione riavvio httpd e verificare i pacchetti installati:

new_php_version

Controllare gli errori moduli / pacchetti:

php-v

Aggiornamento PHP / 32 bit CentOS (i386).

FIX PROBLEMA: Il server è in esecuzione la versione di PHP ma WordPress 5.1.6 3.2.1 5.2.4 richiede almeno.

Circa l'autore

Stealth LP

Fondatore ed editore Stealth ImpostazioniIn data 2006.
L'esperienza sui sistemi Linux operativi (in particolare CentOS), Mac OS X, Windows XP> di Windows 10 e WordPress (CMS).

Lascia un tuo commento

Questo sito utilizza Akismet per ridurre lo spam. Scopri come vengono elaborati i dati dei tuoi commenti.