[Fix phpMyAdmin] Il file di configurazione ora bisogno di una password segreta (blowfish_secret)

sia installatophpMyAdmin server Ubuntu, CentOS o ecc Fedora la distribuzione, il messaggio "Il file di configurazione ora bisogno di una password segreta (blowfish_secret)"In rosso in fondo dell'indice, senza problemi. Soprattutto quando si è impostato correttamente in "/etc/phpMyAdmin/config.inc.php".
Naturalmente, il percorso può variare da una configurazione all'altra, ma la 7 CentOS cu phpMyAdmin installato tramite "yum"In"remi.repo"File di configurazione si troverà in" / etc / phpMyAdmin /".

Bene, vediamo come gestire "Il file di configurazione ora bisogno di una password segreta (blowfish_secret)"Seconfig.inc.php abbiamo questa linea:

$ Cfg [ 'blowfish_secret'] = '$ gNsWq $% #% #% EDFSsffsegbVp6LCJw6w'; / * È necessario compilare QUESTO PER COOKIE AUTH! * /

Se questa linea è presente e noi abbiamo una "chiave" su personaggi 32 in phpMyAdmin messaggio rosso dovrebbe scomparire.
Nel caso in cui questo non è accaduto, è necessario eliminare i cookie dal vostro browser e accedere di phpMyAdmin. Al successivo accesso, il messaggio "Il file di configurazione ora bisogno di una password segreta (blowfish_secret)"Io non sarò presente.
Anche se vi sono situazioni in cui è presente non a causa di configurazioni errate il file config.inc.php, ma a causa di permessi della cartella in cui era.

Eseguire in linea comando da terminale:

 radice chown -R: nginx / etc / phpMyAdmin /

Ora tutto dovrebbe andare bene. Se usi Apache, invece di user: nginx, imposta "httpd" o il modo in cui hai l'utente del processo web sul server.

Ho scritto questo consigli, perché mi sono girato nel giro di ore 2 tutto il config phpMyAdmin, e ancora non può sfuggire il messaggio: Il file di configurazione ora bisogno di una password segreta (blowfish_secret). Dopo autorizzazioni risolti / gruppi, scomparso.

[Fix phpMyAdmin] Il file di configurazione ora bisogno di una password segreta (blowfish_secret)

Circa l'autore

Stealth LP

Fondatore ed editore Stealth ImpostazioniIn data 2006.
L'esperienza sui sistemi Linux operativi (in particolare CentOS), Mac OS X, Windows XP> di Windows 10 e WordPress (CMS).

Lascia un tuo commento

Questo sito utilizza Akismet per ridurre lo spam. Scopri come vengono elaborati i dati dei tuoi commenti.